Back to overview
Downtime

We are performing maintenance

Mar 25, 2026 at 9:00am UTC
Affected services
glowcose.io
glowcose.com
Glowcose API
Glowcose <-> Dexcom
Glowcose <-> FreeStyle Libre
Glowcose <-> Nightscout
Glowcose Notification System

Resolved
Mar 25, 2026 at 10:00am UTC

We accomplished the maintenance. We are sorry for any inconvenience.

Created
Mar 25, 2026 at 9:00am UTC

Glowcose service won't be available during the period between 11:00 am and 11:59 am EET