Back to overview
Downtime
Libre Connection Interruption.
Oct 08 at 09:45am HDT
Affected services
Glowcose <-> FreeStyle Libre
Resolved
Oct 08 at 11:36pm HDT
The situation has been resolved.
Affected services
Created
Oct 08 at 09:45am HDT
We are currently investigating an issue affecting connection statuses for Libre devices. Our engineering team is actively working on a resolution and we expect to have service fully restored within the next 24 hours. We will post another update as soon as more information is available.
Affected services