Back to overview
Degraded
Glowcose specific Libre API Instability
Jun 23 at 03:58pm HDT
Affected services
Glowcose <-> FreeStyle Libre
Resolved
Jun 24 at 05:01am HDT
Stability issues related to the glowcose <-> Libre connection have been resolved. Thank you for your patience!
Affected services
Glowcose <-> FreeStyle Libre
Created
Jun 23 at 03:58pm HDT
We're aware of some instability currently impacting some users. We're currently working to resolve the issue as quickly as possible.
Affected services